Everything can do it :p

Blog

Author: svck

Konfigurasi VLC menggunakan metode Tunnel EoIP Mikrotik

Posted by in streaming vlc on

Banyak cara untuk mengirim video streaming ke tujuan, mau live di youtube atau dipasang di server web kita sendiri.
Menggunakan VLC yang sangat mudah, tapi kalo harus melewati banyak hop kita tidak akan bisa melewatkan multicast, dan banyak provider yang tidak bisa open multicast port.
Solusi yang sudah tested bisa menggunakan metode Layer 2 Tunnel EoIP Mikrotik.

Berikut penjelasan awal mengenai Multicast, Unicast dan Broadcast

Unicast
Unicast adalah pengiriman pesan ke satu tujuan jaringan host di jaringan switching paket. Unicast disetting agar streaming hanya dapat ditujukan pada 1 IP yang diizinkan

Multicast
Multicasting adalah sebuah teknik di mana sebuah data dikirimkan melalui jaringan ke sekumpulan komputer yang tergabung ke dalam sebuah grup tertentu, yang disebut sebagai multicast group.

Broadcast
Broadcast yang juga dikenal sebagai metode transmisi one to all ( satu kesemua). Broadcast disetting agar streaming dapat dilakukan untuk semua PC client yang ada dan dilakukan dalam waktu yang bersamaan.

==============================================================

Requirement :
-Router Mikrotik di dua sisi
-IP Public Static di masing router, Jika IP Public Dynamic di Setting VPN dahulu antar router kemudian Tunnel EoIP
-PC yang sudah terinstall VLC

==============================================================

Konfigurasi di sisi Router A

/interface eoip
add allow-fast-path=no disabled=yes !keepalive local-address=10.10.8.1 \
mac-address=xxxxxxxx name=eoip-tunnel-TV remote-address=(IP RO B) tunnel-id=222

/interface bridge
add fast-forward=no name=bridgeTV
/interface bridge port
add bridge=bridgeTV interface=ether3-to-PC1
add bridge=bridgeTV interface=eoip-tunnel-TV

/routing igmp-proxy interface
add interface=ether3-to-PC1
add interface=eoip-tunnel-TV

Konfigurasi di sisi Router B

/interface eoip
add allow-fast-path=no disabled=yes !keepalive local-address=10.10.8.2 \
mac-address=xxxxxxxx name=eoip-tunnel-TV remote-address=(IP RO A) tunnel-id=222

/interface bridge
add fast-forward=no name=bridgeTV
/interface bridge port
add bridge=bridgeTV interface=ether3-to-PC2
add bridge=bridgeTV interface=eoip-tunnel-TV

/routing igmp-proxy interface
add interface=ether3-to-PC2
add interface=eoip-tunnel-TV

Pengetesan bisa dilakukan dengan test koneksi dari PC1 dan PC2 karena sudah menjadi satu network, dan pengetesan ini saya menggunakan ip 10.10.77.0/30

 

Limit Attachment User Email / Account Cpanel

Posted by in cpanel on

Kali ini ada permintaan dari salah satu teman, untuk limit attachment user tertentu.

Berhubung user email untuk HRD keperluan attachmentnya kadang-kadang sampai maximum si attachment tersebut, misalkan di gmail itu bisa kirim sampe 25 Megabyte

Nah begini solusi nya

1. Login root remote by ssh

2.  contoh jika attachment di Akun Cpanel dilimit 3 M per attachment

Edit file /etc/vfilters/yourdomain.com and paste the following rule :



# Exim filter
#Rule1
if
 $message_body_size is above 3M then
mail
to $sender_address
from [email protected]
subject "RE: $header_subject:"
fail "Your message was over 3MB size limit and so it was not delivered."
seen finish
endif
3. Limit per User email dengan maximal 1 Mbyte
#Rule2
if
 $message_body_size is above 1M then
mail
subject “RE: $header_subject:”
fail “Your message was over 1MB size limit and so it was not delivered.”
seen finish
endif
4. Dan si pengirim email akan mendapat Mailer Daemon atau Bouncing email bahwa email tidak dapat terkirim
Sekian

SSL Gratis dari Lets Encrypt

Posted by in servers ssl on

SSL adalah Secure Socket Layer(SSL) protokol keamanan yang mengamankan semua bentuk transaksi yang ada di website Anda. Mulai dari sekedar akses website hingga transaksi yang sensitif seperti pendaftaran, online shopping, email, hingga transaksi kartu kredit.

Atau kata lainnya untuk membuat hijau address bar di browser kita (hehe). dengan asumsi web kita dapat dipercaya.

Ok, saya bagikan triknya untuk mendapatkan SSL Gratis dari Lets Encrypt.

Instalasi Lets Encrypt :

Saya disini menggunakan Ubuntu 14.04

yum install git

# Clone repo ke direktori /opt/letsencrypt

git clone https://github.com/letsencrypt/letsencrypt /opt/letsencrypt

cd /opt/letsencrypt

./letsencrypt-auto --help

Buat folder /etc/letsencrypt dengan menjalankan perintah berikut:

mkdir /etc/letsencrypt

Setelah itu buat file konfigurasi di folder /etc/letsencrypt dengan ekstensi .ini misal domain.ini dan paste teks berikut:

# This is an example of the kind of things you can do in a configuration file.
# All flags used by the client can be configured here. Run Let's Encrypt with
# "--help" to learn more about the available options.

# Use a 4096 bit RSA key instead of 2048
rsa-key-size = 4096

# Uncomment and update to register with the specified e-mail address
email = [email protected]

# Uncomment and update to generate certificates for the specified
# domains.
domains = example.com, www.example.com

# Uncomment to use a text interface instead of ncurses
# text = True

# Uncomment to use the standalone authenticator on port 443
# authenticator = standalone
# standalone-supported-challenges = tls-sni-01

# Uncomment to use the webroot authenticator. Replace webroot-path with the
# path to the public_html / webroot folder being served by your web server.
# authenticator = webroot
# webroot-path = /usr/share/nginx/html

Catatan:

  • Ganti opsi email dengan email kamu untuk notifikasi ketika sertifikat akan expire.
  • Untuk opsi domains isikan semua domain kamu yang ingin dibuatkan SSL-nya. Ingat untuk memisahkan dengan koma untuk tiap domainnya.

Kita tinggal membuat SSL untuk domain yang sudah kita tuliskan diatas dengan menjalankan perintah seperti berikut:

# Matikan webservernya

service apache2 stop

# Masuk ke folder /opt/letsencrypt

cd /opt/letsencrypt

# Generate SSL

./letsencrypt-auto certonly --standalone --agree-tos --renew-by-default --config /etc/letsencrypt/domain.ini

# Nyalakan lagi webservernya

service apache2 start

SSL akan tercipta di folder /etc/letsencrypt/live dan untuk nama menggunakan domain pertama pada opsi domains di file konfigurasinya misal example.com.

Ada 3 buah file berekstensi .pem yang kita perlukan yaitu: cert.pem, chain.pem, dan privkey.pem.

Instalasi SSL ke Webserver

Saya menggunakan webserver Apache dan kita cukup menambahkan SSL yang ada ke virtual host. Contoh:

<virtualhost *:80>
    ServerName example.com
    ServerAlias example.com www.example.com
    Redirect permanent / https://www.example.com/
</VirtualHost>

<virtualhost *:443>
    ServerName example.com
    ServerAlias example.com www.example.com
    ServerAdmin [email protected]
    DocumentRoot /var/www/html/example.com
    ErrorLog /var/log/httpd/example.com_error.log
    CustomLog /var/log/httpd/example.com_access.log combined
    <Directory "/var/www/html/example.com">
        Options FollowSymLinks Indexes
        AllowOverride All
        Order Allow,Deny
        Allow from all
        DirectoryIndex index.php
    </Directory>
    SSLEngine on
    SSLProtocol ALL -SSLv2 -SSLv3
    SSLHonorCipherOrder On
    SSLCipherSuite ECDH+AESGCM:DH+AESGCM:ECDH+AES256:DH+AES256:ECDH+AES128:DH+AES:ECDH+3DES:DH+3DES:RSA+AESGCM:RSA+AES:RSA+3DES:!aNULL:!MD5:!DSS
    SSLCertificateFile /etc/letsencrypt/live/example.com/cert.pem
    SSLCertificateKeyFile /etc/letsencrypt/live/example.com/privkey.pem
    SSLCertificateChainFile /etc/letsencrypt/live/example.com/chain.pem
</VirtualHost>

Catatan: Ganti example.com dengan domain SSL kamu.

 

Auto-renew Let’s Encrypt

Masa berlaku dari SSL-nya hanya 90 hari jadi solusi yang paling tepat adalah kita membuat script bash yang dipadukan dengan cron untuk memperpanjang SSL secara otomatis jika sudah akan expire.

Pertama buat script bash-nya:

vi /etc/letsencrypt/le-renew

Isikan dengan script berikut:

#!/bin/bash

web_service='httpd'
config_file="/etc/letsencrypt/domain.ini"
le_path='/opt/letsencrypt'
exp_limit=30;

if [ ! -f $config_file ]; then
    echo "[ERROR] config file does not exist: $config_file"
    exit 1;
fi

domain=`grep "^\s*domains" $config_file | sed "s/^\s*domains\s*=\s*//" | sed 's/(\s*)\|,.*$//'`
cert_file="/etc/letsencrypt/live/$domain/fullchain.pem"

if [ ! -f $cert_file ]; then
    echo "[ERROR] certificate file not found for domain $domain."
fi

exp=$(date -d "`openssl x509 -in $cert_file -text -noout|grep "Not After"|cut -c 25-`" +%s)
datenow=$(date -d "now" +%s)
days_exp=$(echo \( $exp - $datenow \) / 86400 |bc)

echo "Checking expiration date for $domain..."

if [ "$days_exp" -gt "$exp_limit" ] ; then
    echo "The certificate is up to date, no need for renewal ($days_exp days left)."
    exit 0;
else
    echo "The certificate for $domain is about to expire soon. Starting webroot renewal script..."
    echo "Stopping $web_service"
    service $web_service stop
    $le_path/letsencrypt-auto certonly --standalone --agree-tos --renew-by-default --config $config_file
    echo "Starting $web_service"
    service $web_service start
    echo "Renewal process finished for domain $domain"
    exit 0;
fi

Setelah disimpan pastikan script tersebut bisa dieksekusi:

chmod +x /etc/letsencrypt/le-renew

Sekarang kita hanya perlu membuat cron yang berjalan satu minggu sekali untuk mengecek apakah SSL sudah mau expire dan jika SSL akan expire kurang dari 30 hari maka otomatis script bash akan me-renew sertifikatnya.

# Membuka crontab

crontab -e

# Isikan baris berikut

30 2 * * 1 /etc/letsencrypt/le-renew > /var/log/le-renew.log 2>&1

 

 


 

Tugas UAS Manajemen Proyek

Posted by in Tugas on

Pimpinan Teladan

Setiap dari kita adalah pemimpin yang harus siap untuk memimpin apa dan siapa yang kita pimpin. Hanya saja posisi atau status turut menentukan sebesar apa tanggungjawab kita sebagai pemimpin. Jika sebagai presiden, maka sudah barang tentu ia memimpin suatu negara yang tanggungjawabnya tentu sangat besar mencakup hal ikhwal satu negara, jika sebagai gubernur, maka ia mempunyai tanggungjawab memimpin masyarakat satu provinsi, begitu juga seseorang sebagai individu maka sudah barang tentu ia bertanggungjawab memimpin dirinya sendiri.

Mengenai konsep kepemimpinan yang hal ini saya temukan dalam bangku kuliah, bahwa kepemimpinan itu merupakan suatu karakter dari seorang pemimpin yang mana salah satunya seseorang pemimpin harus menjadi teladan bagi orang lain atau bagi masyarakat yang dipimpinnya. Layaknya posisi seorang ibu dan ayah bagi anak dalam lingkungan keluarga, maka seorang pemimpin juga seolah menjadi orang tua bagi masyarakat yang dipimpinnya, masyarakat tersebut pada akhirnya akan mencontoh apa yang dilakukan oleh pemimpin.

Disamping orangtua sebagai suri tauladan bagi saya, saya juga sangat kagum kepada Presiden ke 2, yaitu Bpk Soeharto, Beliau bisa dikatakan pemimpin teladan menurut saya, meskipun saya hanya merasakan kepemimpinan beliau disaat saya kecil ( 10 tahun). tapi aman dan tentram, rakyat sejahtera, swasembada pangan negara kita kuat. Negara kita di kenal macan asia (katanya), Beliau sangat dekat dengan rakyatnya dari kalangan elit atau biasa, harga sandang pangan kita di atur oleh MPR untuk mengontrol daya beli rakyatnya.

Dalam hal ini kepemimpinan yang saya teladani tidak dari satu orang saja. melainkan banyak profesi yang menginspirasi saya untuk memimpin hidup saya sendiri.

Tujuan Hidup dan Cita-cita memang saya miliki waktu kecil, cita-cita saya waktu kecil yaitu menjadi guru SD yang sudah PNS, karena zaman sekarang banyak yang guru honorer (:sad) makanya saya perjelas cita-citanya. 😀

guru

Kenapa guru SD ?

Ya, yang kepikiran waktu kecil itu guru adalah orang yang paling berjasa mengubah seseorang mulai dari usia dini, diluar daripada keluarga. Lulusan SD berpengaruh terhadap kelanjutan siswa ke SMP, mungkin juga dinilai dari kualitas guru nya yang pada waktu itu dinilai dari NEM.

Mengubah pola pikir baiknya pada usia dini, dan harus di tanamkan pada setiap anak. Itulah cita-cita saya yang kagum pada profesi seorang guru SD.

Seiring berjalannya waktu menjadi Guru SD adalah pilihan sulit dan susah tentunya. Guru sekarang banyak dengan status Honorer, memberatkan sekali profesi ini namun hasilnya sangat kurang bagi Honorer. Saya berpikir untuk mengesampingkan mengejar cita-cita ini terlebih dahulu.

Awal mula dari ketidaktahuan pada jurusan yang di ambil pada waktu SMK, saya dengan entengnya ngambil jurusan yang ada kata-kata “Komputer” mungkin jurusan ini lebih mudah dan tidak terlalu membebankan meski pada waktu itu saya belum punya komputer, bahkan pada waktu SMP pelajaran komputer selalu saya tinggalkan. :V tapi alhamdulillah saya sekarang bekerja di bidang IT dan tentunya didepan komputer terus. :)

Cita-cita menjadi guru SD akan saya lakukan mungkin di lain waktu, akan tetapi untuk saat ini saya akan menimba ilmu atau pengalaman di bidang IT lebih luas lagi dan sempat kepikiran menjadi Praktisi IT atau IT Consultant.

IT-Consulting1

Tujuan Hidup, tetap dan tidak akan berubah yaitu menjadi orang yang berguna bagi Orang tua, Masyarakat, bahkan dunia sekaligus.  Saya akan jadi Guru atau menjadi Pemimpin perusahaan pun akan saya iringi dengan tujuan hidup saya ini.

Berdo’a, Berusaha, dan Let it flow….

Block Whatsapp dan BBM di Mikrotik

Posted by in mikrotik on

Halo…
Selamat sehat, kali ini saya mau membagi tips berhubung ada temen yang minta buat setinagn kantor nya.
Wifi mau di akses hanya buat whatsapp sama bbm, setelah ngutak ngatik cari IP CIDR kedua aplikasi itu akhirnya ketemu,
ni sekalian mau share aja ya, berbagi ilmu ga bakal ngurangin ilmu mu…

==================================================
List IP BBM
==================================================
/ip firewall address-list

******kopi paste kanu new terminal********

add address=206.51.26.0/24 disabled=no list=bbm
add address=193.109.81.0/24 disabled=no list=bbm
add address=204.187.87.0/24 disabled=no list=bbm
add address=206.53.144.0/20 disabled=no list=bbm
add address=216.9.240.0/20 disabled=no list=bbm
add address=67.223.64.0/19 disabled=no list=bbm
add address=93.186.16.0/21 disabled=no list=bbm
add address=208.65.72.0/21 disabled=no list=bbm
add address=68.171.224.0/19 disabled=no list=bbm
add address=74.82.64.0/19 disabled=no list=bbm
add address=173.247.32.0/19 disabled=no list=bbm
add address=178.239.80.0/20 disabled=no list=bbm

===================================================
List IP Whatsapp
===================================================
http://www.whatsapp.com/cidr.txt

/ip firewall address-list

******kopi paste kanu new terminal********

add address=31.13.64.51/32 disabled=no list=whatsapp
add address=31.13.65.49/32 disabled=no list=whatsapp
saruakeun
31.13.66.49/32
31.13.67.51/32
31.13.69.240/32
31.13.70.49/32
31.13.71.49/32
31.13.72.52/32
31.13.73.49/32
31.13.74.49/32
31.13.75.52/32
31.13.76.81/32
31.13.77.49/32
31.13.79.195/32
31.13.80.53/32
31.13.81.53/32
31.13.82.51/32
31.13.83.51/32
31.13.84.51/32
31.13.85.51/32
31.13.86.51/32
31.13.87.51/32
31.13.88.49/32
31.13.88.57/32
31.13.90.51/32
31.13.91.51/32
31.13.92.52/32
31.13.93.51/32
31.13.95.63/32
50.22.75.192/27
50.22.93.192/27
50.22.198.204/30
50.22.210.32/30
50.22.210.128/27
50.22.225.64/27
50.22.235.248/30
50.22.240.160/27
50.23.90.128/27
50.97.57.128/27
75.126.39.32/27
108.168.174.0/27
108.168.176.192/26
108.168.177.0/27
108.168.180.96/27
108.168.254.65/32
108.168.255.224/32
108.168.255.227/32
158.85.0.96/27
158.85.5.192/27
158.85.46.128/27
158.85.48.224/27
158.85.58.0/25
158.85.61.192/27
158.85.224.160/27
158.85.233.32/27
158.85.249.128/27
158.85.249.224/27
158.85.254.64/27
169.53.29.128/27
169.53.71.224/27
169.53.250.128/26
169.54.2.160/27
169.54.51.32/27
169.54.55.192/27
169.54.210.0/27
169.54.222.128/27
169.55.69.128/26
169.55.74.32/27
169.55.235.160/27
173.192.162.32/27
173.192.219.128/27
173.192.222.160/27
173.192.231.32/27
173.193.205.0/27
173.193.230.96/27
173.193.230.128/27
173.193.230.192/27
173.193.239.0/27
174.36.208.128/27
174.36.210.32/27
174.36.251.192/27
174.37.199.192/27
174.37.215.28/30
174.37.217.64/27
174.37.231.64/27
174.37.243.64/27
174.37.251.0/27
179.60.192.51/32
179.60.193.51/32
179.60.195.51/32
184.173.73.176/28
184.173.136.64/27
184.173.147.32/27
184.173.161.64/32
184.173.161.160/27
184.173.173.116/32
184.173.179.32/27
184.173.195.32/27
184.173.201.32/27
184.173.204.32/27
184.173.250.53/32
192.155.212.192/27
198.11.193.182/31
198.11.212.0/27
198.11.217.192/27
198.11.251.32/27
198.23.80.0/27
198.23.86.224/27
198.23.87.64/27
208.43.115.192/27
208.43.117.79/32
208.43.117.136/32
208.43.122.128/27

****** rek ditambahkeun rek moal ge bebas IPv6 *********
2607:f0d0:1301:17d::/64
2607:f0d0:1b01:d4::/64
2607:f0d0:1b02:14d::/64
2607:f0d0:3003:1bc::/64
2607:f0d0:3004:136::/64
2607:f0d0:3004:174::/64
2607:f0d0:3005:183::/64
2607:f0d0:3006:84::/64
2607:f0d0:3006:af::/64
2607:f0d0:3801:38::/64
2a03:2880:f000:d:face:b00c::167/128
2a03:2880:f001:d:face:b00c::167/128
2a03:2880:f002:10f:face:b00c::167/128
2a03:2880:f003:c0d:face:b00c::167/128
2a03:2880:f004:11:face:b00c::167/128
2a03:2880:f005:11:face:b00c::167/128
2a03:2880:f006:11:face:b00c::167/128
2a03:2880:f007:11:face:b00c::167/128
2a03:2880:f008:11:face:b00c::167/128
2a03:2880:f009:11:face:b00c::167/128
2a03:2880:f00a:12:face:b00c::167/128
2a03:2880:f00b:d:face:b00c::167/128
2a03:2880:f00c:12:face:b00c::167/128
2a03:2880:f00d:d:face:b00c::167/128
2a03:2880:f00e:12:face:b00c::167/128
2a03:2880:f00f:11:face:b00c::167/128
2a03:2880:f011:d:face:b00c::167/128
2a03:2880:f012:d:face:b00c::167/128
2a03:2880:f013:d:face:b00c::167/128
2a03:2880:f014:11:face:b00c::167/128
2a03:2880:f016:13:face:b00c::167/128
2a03:2880:f017:11:face:b00c::167/128
2a03:2880:f018:f:face:b00c::167/128
2a03:2880:f018:10e:face:b00c::167/128
2a03:2880:f019:11:face:b00c::167/128
2a03:2880:f01a:11:face:b00c::167/128
2a03:2880:f01b:11:face:b00c::167/128
2a03:2880:f01c:11:face:b00c::167/128
2a03:2880:f01c:215:face:b00c::167/128
2a03:2880:f01f:11:face:b00c::167/128
2a03:2880:f021:11:face:b00c::167/128
2a03:2880:f022:d:face:b00c::167/128

=========================================
RULE FIREWALL
=========================================

/ip firewall filter

****sesuai urutan kopi paste na*****

add action=accept chain=forward comment=”Accept BBM” dst-address-list=bbm
***lamun hayang segmen IP tertentu nu di block na***
add action=accept chain=forward comment=”Accept BBM” dst-address-list=bbm src-address=IP-LOKAL-Nu-di-block

add action=accept chain=forward comment=”Accept Whatsapp” dst-address-list=whatsapp

***lamun hayang di block kabeh segmen IP lokal****
add action=drop chain=forward comment=”Block Akses internet” src-address=IP LOKAL

Remove Crypto PHP

Posted by in cms on

Terkadang kesal jika website kita ada penyusup yg menggunakan CryptoPHP, yang berarti Spam ini akan menyelinapkan script php ke dalam script site kita.
isinya dengan redirect url ke site-site dan nantinya IP server kita akan terkena blacklist, karena di anggap melakukan flooding http.

Berikut langkah untuk pengecakan dan pencegahan cryptoPHP.

If you have some shell experience , please use the following methods for identifying the malware

1) Quick check for social*.png files ,
find /home/ -type f -iname “social*.png” -exec grep -E -o ‘php.{0,80}’ {} \; -print

if you see any files from the above result , then you must delete those files immediately,

2)Check all png file ,
find /home -type f -iname ‘*.png’ -print0 | xargs -0 file | grep “PHP script” > /root/cryptoinfected.txt

Now check all the files listed in /root/cryptoinfected.txt and remove it

3) Check all other files,
You must need to check all other files too , because it is not only infected by png fines and jpeg files,

4) Use clamav or maldetect
You may please update your clamav database and maldetect database . After that run a scan , this will detect the mallware
freshclam
maldetect -U

Tweets